API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

GraphicsDrawerDrawMeshSurface Method

Draws the mesh surface as temporary graphics in the currently active Tekla Structures rendered view. The counterclockwise sides of the mesh triangles are drawn.

Namespace:  Tekla.Structures.Model.UI
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public bool DrawMeshSurface(
	Mesh Mesh,
	Color Color
)

Parameters

Mesh
Type: Tekla.Structures.Model.UIMesh
The mesh to draw.
Color
Type: Tekla.Structures.Model.UIColor
The color of the mesh.

Return Value

Type: Boolean
True on success.
See Also