API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

GraphicsDrawerDrawLineSegment Method (Point, Point, Color)

Draws a temporary line segment in the currently active rendered view.

Namespace:  Tekla.Structures.Model.UI
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public bool DrawLineSegment(
	Point Point1,
	Point Point2,
	Color Color
)

Parameters

Point1
Type: Tekla.Structures.Geometry3dPoint
The first point of the line.
Point2
Type: Tekla.Structures.Geometry3dPoint
The second point of the line.
Color
Type: Tekla.Structures.Model.UIColor
The color of the line. The transparency value of the color is ignored.

Return Value

Type: Boolean
True on success.
See Also