API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

GraphicsDrawerDrawLineSegment Method (LineSegment, Color)

Draws a temporary line segment in the currently active rendered view.

Namespace:  Tekla.Structures.Model.UI
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public bool DrawLineSegment(
	LineSegment LineSegment,
	Color Color
)

Parameters

LineSegment
Type: Tekla.Structures.Geometry3dLineSegment
The line to draw.
Color
Type: Tekla.Structures.Model.UIColor
The color of the line. The transparency value of the color is ignored.

Return Value

Type: Boolean
True on success.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.