API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

GraphicPolyLineLineType Enumeration

The appearance of the line. For instance solid, dashed or dotted.

Namespace:  Tekla.Structures.Model.UI
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public enum LineType
Members
  Member nameValueDescription
Solid1 The solid line type.
Dashed12 The first dashed line type.
Dashed23 The second dashed line type.
DashedAndDotted4 The dashed and dotted line type.
Dotted5 The dotted line type.
See Also