API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

GraphicPolyLine Constructor (PolyLine, Color, Int32, GraphicPolyLineLineType)

Create a graphic polyline object.

Namespace:  Tekla.Structures.Model.UI
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public GraphicPolyLine(
	PolyLine polyLine,
	Color color,
	int width,
	GraphicPolyLineLineType type
)

Parameters

polyLine
Type: Tekla.Structures.Geometry3dPolyLine
The path of the line.
color
Type: Tekla.Structures.Model.UIColor
The color of the line.
width
Type: SystemInt32
The width of the line.
type
Type: Tekla.Structures.Model.UIGraphicPolyLineLineType
The type of the line. For example solid, dashed or dotted.
See Also