API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

Color Constructor (Double, Double, Double)

Creates a new color object with the given values.

Namespace:  Tekla.Structures.Model.UI
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public Color(
	double Red,
	double Green,
	double Blue
)

Parameters

Red
Type: SystemDouble
The red value of the color, between 0.0 and 1.0.
Green
Type: SystemDouble
The green value of the color, between 0.0 and 1.0.
Blue
Type: SystemDouble
The blue value of the color, between 0.0 and 1.0.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.