API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

Color Class

The Color class represents an RGB color with transparency. The color values must be between 0.0 and 1.0.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.Model.UIColor

Namespace:  Tekla.Structures.Model.UI
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public sealed class Color

The Color type exposes the following members.

Constructors
  NameDescription
Public methodColor
Creates a new color object. The default object is black.
Public methodColor(Double, Double, Double)
Creates a new color object with the given values.
Public methodColor(Double, Double, Double, Double)
Creates a new color object with the given values.
Top
Properties
  NameDescription
Public propertyBlue
The blue value of the color, between 0.0 and 1.0.
Public propertyGreen
The green value of the color, between 0.0 and 1.0.
Public propertyRed
The red value of the color, between 0.0 and 1.0.
Public propertyTransparency
The transparency value of the color, between 0.0 (completely see-through) and 1.0 (completely solid).
Top
Examples
using Tekla.Structures.Model.UI;

public class Example
{
       public void Example1()
       {
           Color SolidGreen = new Color(0.0, 1.0, 0.0);
           Color SeeThroughBlue = new Color(0.0, 0.0, 1.0, 0.5);
       }
}
See Also