API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

OperationProgressBarDisplay Method

Display progress bar dialog with cancel button. Display will fail if progress bar is already displayed.

Namespace:  Tekla.Structures.Model.Operations
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public bool Display(
	int SleepTime,
	string Title,
	string Message,
	string CancelButtonLabel,
	string ProgressLabel
)

Parameters

SleepTime
Type: SystemInt32
Time (ms) to wait until bar is displayed.
Title
Type: SystemString
Title of the dialog.
Message
Type: SystemString
Message to be displayed on the dialog above progress bar.
CancelButtonLabel
Type: SystemString
Label of cancel button.
ProgressLabel
Type: SystemString
Initial progress label (updated with SetProgress). If empty of null no bar exists.

Return Value

Type: Boolean
True if bar was displayed successfully (meaning bar must be closed later).
See Also