API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

OperationOpen Method (String, Boolean)

Note: This API is now obsolete.

Opens a new model to Tekla Structures.

Namespace:  Tekla.Structures.Model.Operations
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
[ObsoleteAttribute("Use the method in ModelHandler class instead. Will be removed in near future.")]
public static bool Open(
	string ModelFolder,
	bool OpenAutoSaved
)

Parameters

ModelFolder
Type: SystemString
The model folder to be used.
OpenAutoSaved
Type: SystemBoolean
Tells whether to open auto saved information or not.

Return Value

Type: Boolean
True on success.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.