API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

OperationIsNumberingUpToDate Method

Checks whether the numbering is up-to-date for an assembly, part, rebar, surface treatment, pour object or break.

Namespace:  Tekla.Structures.Model.Operations
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public static bool IsNumberingUpToDate(
	ModelObject InputModelObject
)

Parameters

InputModelObject
Type: Tekla.Structures.ModelModelObject
The model object to check. The object must be an assembly, a part, a rebar or an inherited object.

Return Value

Type: Boolean
True if the numbering information is up-to-date.
Exceptions
ExceptionCondition
ArgumentExceptionThrown if the InputModelObject is not of a correct type or if it is not valid.
See Also