API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

OperationIsMacroRunning Method

Returns true if a macro is running, false otherwise.

Macros are saved as *.cs files in the folder defined with the XS_MACRO_DIRECTORY variable.

See Tekla Structures Help for more information about macros.

Namespace:  Tekla.Structures.Model.Operations
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public static bool IsMacroRunning()

Return Value

Type: Boolean
True if a macro is running.
See Also