API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

OperationExplodeBentPlate Method

Deletes bentPlate and inserts ContourPlates instances equivalent to the ones used to create bentPlate. The ContourPlate created from the main polygon has the same identifier as bentPlate.

Namespace:  Tekla.Structures.Model.Operations
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public static bool ExplodeBentPlate(
	BentPlate bentPlate
)

Parameters

bentPlate
Type: Tekla.Structures.ModelBentPlate
the BentPlate instance to explode.

Return Value

Type: Boolean

[Missing <returns> documentation for "M:Tekla.Structures.Model.Operations.Operation.ExplodeBentPlate(Tekla.Structures.Model.BentPlate)"]

Exceptions
ExceptionCondition
ArgumentExceptionThrown when bentPlate is invalid.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.