API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

OperationCreateNCFilesFromAll Method (String, String)

Creates NC files from all parts using the given NC template name.

See Tekla Structures Help for more information about NC files.

Namespace:  Tekla.Structures.Model.Operations
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public static bool CreateNCFilesFromAll(
	string NCFileSettings,
	string DestinationFolder
)

Parameters

NCFileSettings
Type: SystemString
The name of the NC setting template to be used in creation.
DestinationFolder
Type: SystemString
The name of the folder where NC files are created. If defined, overrides the default folder in the setting template.

Return Value

Type: Boolean
True if the NC files are created, false if the numbering is not up-to-date or the used configuration is wrong.
Exceptions
ExceptionCondition
ArgumentExceptionThrown when the NCFileSettings is not defined.
ArgumentNullExceptionThrown when the NCFileSettings is null.
Examples
using Tekla.Structures.Model.Operations;
using System.Windows.Forms;

public class Example
{
       public void Example1()
       {
           if (Operation.CreateNCFilesFromAll("DSTV for plates", ""))
               MessageBox.Show("NC creation successful");
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.