![]() | GuidConversion Class |
Conversion of old TS GUIDs to current GUIDs.
GUIDs are changed in TS save as operation, this class can be used to convert old GUIDs to current GUIDs.
To recognize the need for GUID conversion, application needs to save project GUID and compare to the current project GUID.
Note: With big models the instance uses a lot of memory.

Namespace: Tekla.Structures.Model.Operations
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1

The GuidConversion type exposes the following members.

Name | Description | |
---|---|---|
![]() | GuidConversion | Initializes a new instance of the GuidConversion class. |

Name | Description | |
---|---|---|
![]() | GetGuidMapping | Gets the GUID mapping. |
![]() | GetNewGuid | Gets the new GUID. |