API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ModelHistoryTakeModifications Method (String, ModificationStamp)

Take modifications since previous call.

Namespace:  Tekla.Structures.Model.History
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public static ModificationInfo TakeModifications(
	string Name,
	ModificationStamp PrevStamp = null
)

Parameters

Name
Type: SystemString
Name of reference which is used for collecting modifications and which is updated. Intended use is to assign an unique name for each client application which needs to be informed of the model updates. Maximum length is 79 characters.
PrevStamp (Optional)
Type: Tekla.Structures.Model.HistoryModificationStamp
When specified, default value of reference if is it not found

Return Value

Type: ModificationInfo
All modifications which happened since the last call. See ModificationInfo reference
Remarks
Takes modification which has happened to the model since the previous call to TakeModifications with the same Name argument. If there was no previous call with this Name, shows modifications since beginning, or since PrevStap, if it is specified. Updates internal reference for use when TakeModifications() is called next time.
See Also