IFC2X3_ParametricObject_UShapeProfile Class

The IFC2X3_ParametricObject_UShapeProfile class contains the U-shape profile definition.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.Model.CollaborationReferenceModelObjectAttribute
    Tekla.Structures.Model.CollaborationIFC2X3_ParametricObject_UShapeProfile

Namespace:  Tekla.Structures.Model.Collaboration
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class IFC2X3_ParametricObject_UShapeProfile : ReferenceModelObjectAttribute

The IFC2X3_ParametricObject_UShapeProfile type exposes the following members.

Properties
  NameDescription
Public propertyDepth
The depth.
Public propertyEdgeRadius
The edge radius.
Public propertyFilletRadius
The fillet radius.
Public propertyFlangeSlope
The flange slope.
Public propertyFlangeThickness
The flange thickness.
Public propertyFlangeWidth
The flange width.
Public propertyWebThickness
The web thickness.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next