IFC2X3_ParametricObject_UShapeProfile Class

The IFC2X3_ParametricObject_UShapeProfile class contains the U-shape profile definition.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.Model.CollaborationReferenceModelObjectAttribute
    Tekla.Structures.Model.CollaborationIFC2X3_ParametricObject_UShapeProfile

Namespace:  Tekla.Structures.Model.Collaboration
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class IFC2X3_ParametricObject_UShapeProfile : ReferenceModelObjectAttribute

The IFC2X3_ParametricObject_UShapeProfile type exposes the following members.

Properties
  NameDescription
Public propertyDepth
The depth.
Public propertyDescription
The description of the product.
(Inherited from ReferenceModelObjectAttribute.)
Public propertyEdgeRadius
The edge radius.
Public propertyExtrusion
The extrusion vector.
(Inherited from ReferenceModelObjectAttribute.)
Public propertyFilletRadius
The fillet radius.
Public propertyFlangeSlope
The flange slope.
Public propertyFlangeThickness
The flange thickness.
Public propertyFlangeWidth
The flange width.
Public propertyName
The name of the product.
(Inherited from ReferenceModelObjectAttribute.)
Public propertyObjectType
The object type of the product.
(Inherited from ReferenceModelObjectAttribute.)
Public propertyOrigin
The origin of the extrusion.
(Inherited from ReferenceModelObjectAttribute.)
Public propertyProfileName
The name of the profile (often empty).
(Inherited from ReferenceModelObjectAttribute.)
Public propertyWebThickness
The web thickness.
Public propertyxDir
The X-axis direction.
(Inherited from ReferenceModelObjectAttribute.)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next