API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

IFC2X3_ParametricObject_RectangleProfile Class

The IFC2X3_ParametricObject_RectangleProfile class contains the rectangular profile definition.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.Model.CollaborationReferenceModelObjectAttribute
    Tekla.Structures.Model.CollaborationIFC2X3_ParametricObject_RectangleProfile

Namespace:  Tekla.Structures.Model.Collaboration
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public sealed class IFC2X3_ParametricObject_RectangleProfile : ReferenceModelObjectAttribute

The IFC2X3_ParametricObject_RectangleProfile type exposes the following members.

Properties
  NameDescription
Public propertyDescription
The description of the product.
(Inherited from ReferenceModelObjectAttribute.)
Public propertyExtrusion
The extrusion vector.
(Inherited from ReferenceModelObjectAttribute.)
Public propertyName
The name of the product.
(Inherited from ReferenceModelObjectAttribute.)
Public propertyObjectType
The object type of the product.
(Inherited from ReferenceModelObjectAttribute.)
Public propertyOrigin
The origin of the extrusion.
(Inherited from ReferenceModelObjectAttribute.)
Public propertyProfileName
The name of the profile (often empty).
(Inherited from ReferenceModelObjectAttribute.)
Public propertyXDim
The X dimension.
Public propertyxDir
The X-axis direction.
(Inherited from ReferenceModelObjectAttribute.)
Public propertyYDim
The Y dimension.
Top
See Also