API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

IFC2X3_ParametricObject_RectangleProfile Class

The IFC2X3_ParametricObject_RectangleProfile class contains the rectangular profile definition.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.Model.CollaborationReferenceModelObjectAttribute
    Tekla.Structures.Model.CollaborationIFC2X3_ParametricObject_RectangleProfile

Namespace:  Tekla.Structures.Model.Collaboration
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public sealed class IFC2X3_ParametricObject_RectangleProfile : ReferenceModelObjectAttribute

The IFC2X3_ParametricObject_RectangleProfile type exposes the following members.

Properties
  NameDescription
Public propertyXDim
The X dimension.
Public propertyYDim
The Y dimension.
Top
See Also