API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

IFC2X3_ParametricObject_CircleHollowProfile Class

The IFC2X3_ParametricObject_CircleHollowProfile class contains the circular and hollow profile definition.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.Model.CollaborationReferenceModelObjectAttribute
    Tekla.Structures.Model.CollaborationIFC2X3_ParametricObject_CircleHollowProfile

Namespace:  Tekla.Structures.Model.Collaboration
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public sealed class IFC2X3_ParametricObject_CircleHollowProfile : ReferenceModelObjectAttribute

The IFC2X3_ParametricObject_CircleHollowProfile type exposes the following members.

Properties
  NameDescription
Public propertyDescription
The description of the product.
(Inherited from ReferenceModelObjectAttribute.)
Public propertyExtrusion
The extrusion vector.
(Inherited from ReferenceModelObjectAttribute.)
Public propertyName
The name of the product.
(Inherited from ReferenceModelObjectAttribute.)
Public propertyObjectType
The object type of the product.
(Inherited from ReferenceModelObjectAttribute.)
Public propertyOrigin
The origin of the extrusion.
(Inherited from ReferenceModelObjectAttribute.)
Public propertyProfileName
The name of the profile (often empty).
(Inherited from ReferenceModelObjectAttribute.)
Public propertyRadius
The radius.
Public propertyWallThickness
The wall thickness.
Public propertyxDir
The X-axis direction.
(Inherited from ReferenceModelObjectAttribute.)
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.