API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

IFC2X3_ParametricObject_CircleHollowProfile Class

The IFC2X3_ParametricObject_CircleHollowProfile class contains the circular and hollow profile definition.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.Model.CollaborationReferenceModelObjectAttribute
    Tekla.Structures.Model.CollaborationIFC2X3_ParametricObject_CircleHollowProfile

Namespace:  Tekla.Structures.Model.Collaboration
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public sealed class IFC2X3_ParametricObject_CircleHollowProfile : ReferenceModelObjectAttribute

The IFC2X3_ParametricObject_CircleHollowProfile type exposes the following members.

Properties
  NameDescription
Public propertyRadius
The radius.
Public propertyWallThickness
The wall thickness.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.