API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

WorkPlaneHandlerSetCurrentTransformationPlane Method

Sets the current transformation plane.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public bool SetCurrentTransformationPlane(
	TransformationPlane TransformationPlane
)

Parameters

TransformationPlane
Type: Tekla.Structures.ModelTransformationPlane
The transformation plane to be set as the current transformation plane.

Return Value

Type: Boolean
False on failure.
Remarks
Please note that in order to see workplane change visible in the model, use the RedrawWorkplane method of the ViewHandler class.
See Also