API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

TaskGetAllTasksOfSelectedObjects Method

Returns an enumerator of all the tasks related to the selected objects.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public static ModelObjectEnumerator GetAllTasksOfSelectedObjects()

Return Value

Type: ModelObjectEnumerator
A model object enumerator on success, otherwise null.
See Also