API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

SurfaceTreatmentSurfaceColorEnum Enumeration

The different surfacing colors.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public enum SurfaceColorEnum
Members
  Member nameValueDescription
WHITE1 The white surface color.
RED2 The red surface color.
GREEN3 The green surface color.
BLUE4 The blue surface color.
CYAN5 The cyan surface color.
YELLOW6 The yellow surface color.
MAGENTA7 The magenta surface color.
See Also