SurfaceTreatment Class

The SurfaceTreatment class defines a layer above a building element defining what a surface looks like. The surface could for example have a tiled look.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class SurfaceTreatment : ModelObject

The SurfaceTreatment type exposes the following members.

Constructors
  NameDescription
Public methodSurfaceTreatment
Creates a new surface treatment instance.
Top
Properties
  NameDescription
Public propertyClass
The class of the surface treatment.
Public propertyColor
The color of the surfacing.
Public propertyCutByFatherBooleans
Defines if the part is cut by the father's cuts.
Public propertyEndPoint
Determines the direction the surfacing is filled in. The direction is from the start point towards the end point.
Public propertyFather
Defines the father part for the surface treatment: the part that the surface treatment is created on.
Public propertyIdentifier
The identifier of the object.
(Inherited from Object.)
Public propertyIsUpToDate
Gets if the object does not have a modification which is not shared.
(Inherited from ModelObject.)
Public propertyMaterial
Defines the material for the surface treatment.
Public propertyModificationTime
Gets latest time of the object was modified or created.
(Inherited from ModelObject.)
Public propertyName
The name of the surface treatment.
Public propertyPolygon
Defines the area for the surface treatment.
Public propertyPosition
Defines the position for the surface treatment.
Public propertyStartPoint
Determines the origin of the surfacing. The surfacing is then filled out from the start point towards the end point.
Public propertyThickness
Defines how thick the surface treatment is.
Public propertyType
The type of the surfacing.
Public propertyTypeName
The name of the surface treatment type. The valid names are defined in the product_finishes.dat file.
Top
Methods
  NameDescription
Public methodCompareTo
Compares Identifiers of model objects.
(Inherited from ModelObject.)
Public methodDelete
Deletes the surface treatment with the given identifier from the database.
(Overrides ModelObjectDelete.)
Public methodEquals
Check if Identifiers of model objects are same.
(Inherited from ModelObject.)
Public methodCode exampleGetAllReportProperties
Retrieves all properties for the model object in one hashtable. Type for the returned value must be checked using type casting.
(Inherited from ModelObject.)
Public methodGetAllUserProperties
Retrieves all properties for the model object in one hashtable. Type for the returned value must be checked using type casting.
(Inherited from ModelObject.)
Public methodGetChildren
Returns an enumerator of all the children model objects.
(Inherited from ModelObject.)
Public methodGetCoordinateSystem
Returns the coordinate system for the given model object.
(Inherited from ModelObject.)
Public methodGetDoubleReportProperties
Retrieves multiple double report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetDoubleUserProperties
Retrieves all double properties for the model object.
(Inherited from ModelObject.)
Public methodGetDynamicStringProperty
Gets a dynamic string property from the model object.
(Inherited from ModelObject.)
Public methodGetFatherComponent
Returns the father component of the model object.
(Inherited from ModelObject.)
Public methodGetHierarchicObjects
Returns an enumerator of all the connected hierarchic objects.
(Inherited from ModelObject.)
Public methodGetIntegerReportProperties
Retrieves multiple integer report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetIntegerUserProperties
Retrieves all integer properties for the model object.
(Inherited from ModelObject.)
Public methodGetPhase
Retrieves the phase of the model object (the phase number, the phase name, the phase comment and whether the phase is the current one or not).
(Inherited from ModelObject.)
Public methodGetReportProperty(String, Double)
Retrieves a double property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetReportProperty(String, Int32)
Retrieves an integer property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetReportProperty(String, String)
Retrieves a string property of the report for the model object.
(Inherited from ModelObject.)
Public methodGetStringReportProperties
Retrieves multiple string report properties for the model object. It is faster to fetch multiple properties at once.
(Inherited from ModelObject.)
Public methodGetStringUserProperties
Retrieves all string properties for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, Double)
Retrieves a double property for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, Int32)
Retrieves an integer property for the model object.
(Inherited from ModelObject.)
Public methodGetUserProperty(String, String)
Retrieves a string property for the model object.
(Inherited from ModelObject.)
Public methodInsert
Inserts the surface treatment to the database.
(Overrides ModelObjectInsert.)
Public methodModify
Modifies the surface treatment with the given identifier in the database to match the current one.
(Overrides ModelObjectModify.)
Public methodSelect
Selects the surface treatment with the given identifier.
(Overrides ModelObjectSelect.)
Public methodSetDynamicStringProperty
Sets a dynamic string property for the model object.
(Inherited from ModelObject.)
Public methodSetLabel
Sets a label for an object when a new instance is created, this method must be called before Insert. The label is used in plug-ins for identifying the changed object in modification.
(Inherited from ModelObject.)
Public methodSetPhase
Sets the phase of the model object.
(Inherited from ModelObject.)
Public methodSetUserProperties
Sets multiple properties for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, Double)
Sets a double property for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, Int32)
Sets an integer property for the model object.
(Inherited from ModelObject.)
Public methodSetUserProperty(String, String)
Sets a string property for the model object.
(Inherited from ModelObject.)
Top
Examples
using Tekla.Structures.Model;
using Tekla.Structures.Geometry3d;

public class Example
{
       public void Example1()
       {
           ContourPlate cp = new ContourPlate();
           cp.Profile.ProfileString = "PL10";
           cp.Class = "3";
           cp.AddContourPoint(new ContourPoint(new Point( 6000,  6000,0),null));
           cp.AddContourPoint(new ContourPoint(new Point( 9000,  6000,0),null));
           cp.AddContourPoint(new ContourPoint(new Point( 9000, 12000,0),null));
           cp.AddContourPoint(new ContourPoint(new Point(10500, 15000,0),null));
           cp.AddContourPoint(new ContourPoint(new Point( 6000, 12000,0),null));

           Contour c = new Contour();
           c.AddContourPoint(new ContourPoint(new Point( 6000,  6000,5), null));
           c.AddContourPoint(new ContourPoint(new Point( 9000,  6000,5), null));
           c.AddContourPoint(new ContourPoint(new Point( 9000, 12000,5), null));
           c.AddContourPoint(new ContourPoint(new Point(10500, 15000,5), null));
           c.AddContourPoint(new ContourPoint(new Point( 7500, 12000,5), null));

           cp.Insert();

           SurfaceTreatment treatment = new SurfaceTreatment();
           treatment.Father = cp;
           treatment.Polygon = c;
           treatment.StartPoint = new Point(1500,0000,0);
           treatment.EndPoint = new Point(1500,6000,0);

           bool Result = false;
           Result = treatment.Insert();
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next