API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

SurfaceObjectFather Property

Gets or sets the father object of the surface object. The father can be set only before the Insert(), otherwise exception is thrown.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public ModelObject Father { get; set; }

Property Value

Type: ModelObject
Exceptions
ExceptionCondition
InvalidOperationExceptionThrown when the father is tried to set after Insert().
See Also