![]() | StrandUnbondingData Class |
The StrandUnbondingData class represents the unbonding of a rebar strand.

Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1

The StrandUnbondingData type exposes the following members.

Name | Description | |
---|---|---|
![]() | StrandUnbondingData |
Initializes a new strand unbonding data instance with empty attributes.
|

Name | Description | |
---|---|---|
![]() | FromEnd |
The unbonding from the end of the strand.
|
![]() | FromStart |
The unbonding from the start of the strand.
|
![]() | MiddleToEnd |
The unbonding from the middle of the strand to the end of the strand.
|
![]() | MiddleToStart |
The unbonding from the middle of the strand
to the start of the strand.
|
![]() | StrandIndex |
The index of the strand.
|

using Tekla.Structures.Model; public class Example { public void Example1() { StrandUnbondingData Unbonding = new StrandUnbondingData(); Unbonding.FromEnd = 20; Unbonding.FromStart = 20; Unbonding.MiddleToEnd = 30; Unbonding.MiddleToStart = 30; Unbonding.StrandIndex = 1; } }