API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

SpiralBeamDataException Class

The SpiralBeamDataException class represents an error that occurred during the spiral beam creation or modification.
Inheritance Hierarchy
SystemObject
  SystemException
    Tekla.Structures.ModelSpiralBeamDataException

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public class SpiralBeamDataException : Exception

The SpiralBeamDataException type exposes the following members.

Constructors
  NameDescription
Public methodSpiralBeamDataException
Initializes a new instance of the SpiralBeamDataException class with spiral beam error message based on status.
Top
Fields
  NameDescription
Public fieldErrorStatus
Contains error status during spiral beam creation/modification.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.