API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

SolidIntersect Method (Point, Point)

Returns a list of line - solid intersection points.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public ArrayList Intersect(
	Point point1,
	Point point2
)

Parameters

point1
Type: Tekla.Structures.Geometry3dPoint
The first end of the intersection line.
point2
Type: Tekla.Structures.Geometry3dPoint
The second end of the intersection line.

Return Value

Type: ArrayList
A list of intersection points.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.