API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

SolidGetEdgeEnumerator Method

Returns a new edge enumerator in the current plane.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public EdgeEnumerator GetEdgeEnumerator()

Return Value

Type: EdgeEnumerator
An edge enumerator to enumerate through the solid's global edges.

Implements

ISolidGetEdgeEnumerator
See Also