Seam Class

The Seam class represents a seam. A seam is something that connects a main part to other parts along an edge.
Inheritance Hierarchy

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class Seam : BaseComponent

The Seam type exposes the following members.

Constructors
  NameDescription
Public methodSeam
Creates a new seam instance.
Top
Properties
  NameDescription
Public propertyAutoDirectionType
The auto direction type. Default value is AUTODIR_BASIC. Value should be AUTODIR_NA to set direction with UpVector property. Value should be AUTODIR_FROM_ATTRIBUTE_FILE to set direction with seam attribute file.
Public propertyAutoPosition
The auto position type. Defines that the seam will internally evaluate the final position more accurately. The input positions are still needed for reference.
Public propertyClass
The class of the seam.
Public propertyCode
The code of the seam. The code can be used to classify the seam. The code can be reported and shown in drawings. The maximum length of the string is 20 characters.
Public propertyStatus
The read only status of the seam. The status can be reported and shown in drawings. The color of the connection symbol in the model indicates the status of the seam.
Public propertyUpVector
A vector indicating which direction is considered the up direction for the seam.
Top
Methods
  NameDescription
Public methodDelete
Deletes the seam instance with the given ID from the model database.
(Overrides ModelObjectDelete.)
Public methodGetInputPolygon
Returns the input polygon of the seam.
Public methodGetPrimaryObject
Returns the primary object.
Public methodGetSecondaryObjects
Returns an array list containing all the secondary objects.
Public methodGetStartAndEndPositions
Returns the start and end points of the seam.
Public methodInsert
Inserts the seam into the model database. All the attributes must be set.
(Overrides ModelObjectInsert.)
Public methodModify
Modifies the existing seam in the model database to match the current one.
(Overrides ModelObjectModify.)
Public methodSelect
Selects a seam from the model database. The seam ID must be set.
(Overrides ModelObjectSelect.)
Public methodSetInputPolygon
Sets the input polygon of the seam.
Public methodSetInputPositions
Sets the start and end point of the seam.
Public methodSetPrimaryObject
Sets the primary object.
Public methodSetSecondaryObject
Sets the secondary object of the seam. Use this method if you wish to add only one secondary object to the seam.
Public methodSetSecondaryObjects
Sets the secondary objects.
Top
Examples
using Tekla.Structures.Model;
using Tekla.Structures.Geometry3d;
using Tekla.Structures;
using System;

public class Example
{
       public void Example1()
       {
           Beam B1 = new Beam(new Point(15000,3000,0), new Point(21000,3000,0));
           B1.Profile.ProfileString = "780*380";
           B1.Material.MaterialString = "K40-1";
           B1.Class = "5";
           B1.Position.Plane = Position.PlaneEnum.MIDDLE;
           B1.Position.Rotation = Position.RotationEnum.TOP;
           B1.Position.Depth = Position.DepthEnum.BEHIND;

           Beam B2 = new Beam(new Point(15000,3000,0), new Point(21000,3000,0));
           B2.Profile.ProfileString = "780*380";
           B2.Material.MaterialString = "K40-1";
           B2.Class = "6";
           B2.Position.Plane = Position.PlaneEnum.MIDDLE;
           B2.Position.Rotation = Position.RotationEnum.TOP;
           B2.Position.Depth = Position.DepthEnum.FRONT;

           B1.Insert();
           B2.Insert();

           Seam S = new Seam();
           S.Name = "seamdm";
           S.Number = -1;
           S.LoadAttributesFromFile("standard");
           S.UpVector = new Vector(0,0,0);
           S.AutoDirectionType = AutoDirectionTypeEnum.AUTODIR_BASIC;
           S.AutoPosition = true;

           S.SetPrimaryObject(B1);
           S.SetSecondaryObject(B2);

           S.SetInputPositions(new Point(15000,3000,0), new Point(21000,3000,0));

           if(!S.Insert())
               Console.WriteLine("Seam Insert failed");
           else
               Console.WriteLine(S.Identifier.ID);
       }
}
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next