API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ReinforcementGetRebarGeometriesWithoutClashes Method

Retrieves a list of physical reinforcing bars (of type RebarGeometry). These objects contain physical points in the 3D space of each reinforcing bar as shown in model view. In case rebar polygon clashes with itself, physical points are moved to avoid clashing.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public ArrayList GetRebarGeometriesWithoutClashes(
	bool withHooks
)

Parameters

withHooks
Type: SystemBoolean
A parameter to determine whether the hook points should be included in the rebar geometry or not.

Return Value

Type: ArrayList
An array list that contains the RebarGeometry objects.
See Also