API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ReferenceModelRevision Constructor

Parameterized constructor.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public Revision(
	int referenceModelId,
	int id,
	DateTime time,
	string hash,
	string fileName,
	bool isCurrentRevision
)

Parameters

referenceModelId
Type: SystemInt32

[Missing <param name="referenceModelId"/> documentation for "M:Tekla.Structures.Model.ReferenceModel.Revision.#ctor(System.Int32,System.Int32,System.DateTime,System.String,System.String,System.Boolean)"]

id
Type: SystemInt32

[Missing <param name="id"/> documentation for "M:Tekla.Structures.Model.ReferenceModel.Revision.#ctor(System.Int32,System.Int32,System.DateTime,System.String,System.String,System.Boolean)"]

time
Type: SystemDateTime

[Missing <param name="time"/> documentation for "M:Tekla.Structures.Model.ReferenceModel.Revision.#ctor(System.Int32,System.Int32,System.DateTime,System.String,System.String,System.Boolean)"]

hash
Type: SystemString

[Missing <param name="hash"/> documentation for "M:Tekla.Structures.Model.ReferenceModel.Revision.#ctor(System.Int32,System.Int32,System.DateTime,System.String,System.String,System.Boolean)"]

fileName
Type: SystemString

[Missing <param name="fileName"/> documentation for "M:Tekla.Structures.Model.ReferenceModel.Revision.#ctor(System.Int32,System.Int32,System.DateTime,System.String,System.String,System.Boolean)"]

isCurrentRevision
Type: SystemBoolean

[Missing <param name="isCurrentRevision"/> documentation for "M:Tekla.Structures.Model.ReferenceModel.Revision.#ctor(System.Int32,System.Int32,System.DateTime,System.String,System.String,System.Boolean)"]

See Also