API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ReferenceModelRevision Structure

Reference model revision.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public struct Revision

The ReferenceModelRevision type exposes the following members.

Constructors
Properties
  NameDescription
Public propertyFileName
Gets the revision file name.
Public propertyHash
Gets the revision hash identifier.
Public propertyId
Gets the revision id.
Public propertyIsCurrentRevision
Gets the value indicating whether this revision is the current revision or not.
Public propertyReferenceModelId
Gets or sets the parent reference model id.
Public propertyTime
Gets the revision time.
Top
See Also