API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ReferenceModel Constructor

Initializes a new instance of the ReferenceModel class.

The default values are as follows:

  • Filename = string.Empty;
  • ActiveFilePath = string.Empty;
  • ProjectGUID = Guid.Empty;
  • ModelGUID = Guid.Empty;
  • VersionGUID = Guid.Empty;
  • Position = new Point();
  • Scale = 1.0;
  • Visibility = VisibilityEnum.VISIBLE;
  • BasePointGuid = string.Empty;

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public ReferenceModel()
See Also