![]() | RebarSplitter Class |
The RebarSplitter class represents a modifier that can split the RebarSet reinforcing bars that pass through it.

SystemObject
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelBaseRebarModifier
Tekla.Structures.ModelRebarSplitter
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelBaseRebarModifier
Tekla.Structures.ModelRebarSplitter
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1

The RebarSplitter type exposes the following members.

Name | Description | |
---|---|---|
![]() | RebarSplitter |
Initializes a new instance of the RebarSplitter class.
|

Name | Description | |
---|---|---|
![]() | BarsAffected |
Gets or sets the reinforcing bars affected.
(Inherited from BaseRebarModifier.) |
![]() | Cranking |
Gets or sets the rebar cranking.
|
![]() | Curve |
Gets or sets the geometric Contour of the rebar modifier.
(Inherited from BaseRebarModifier.) |
![]() | Father |
Gets or sets the RebarSet to which the modifier belongs.
Only reinforcing bars generated by this RebarSet can be modified by this rebar modifier.
(Inherited from BaseRebarModifier.) |
![]() | FirstAffectedBar |
Gets or sets the first affected bar.
If set to zero, the first affected bar will be chosen automatically.
(Inherited from BaseRebarModifier.) |
![]() | FollowEdges |
Gets or sets a flag that indicates whether the modifier should attempt to follow
the leg face edges located between its end points.
(Inherited from BaseRebarModifier.) |
![]() | Identifier |
The identifier of the object.
(Inherited from Object.) |
![]() | IsUpToDate | Gets if the object does not have a modification which is not shared. (Inherited from ModelObject.) |
![]() | Lapping |
Gets or sets the rebar lapping.
|
![]() | ModificationTime | Gets latest time of the object was modified or created. (Inherited from ModelObject.) |
![]() | SplitOffset |
Gets or sets the offset of the split from the location of the rebar splitter.
|
![]() | SplitType |
Gets or sets the split type.
|
![]() | StaggerOffset |
Gets or sets the additional offset (stagger) of the split location for every other split reinforcing bar.
|
![]() | StaggerType |
Gets or sets the stagger type.
|

Name | Description | |
---|---|---|
![]() | CompareTo |
Compares Identifiers of model objects.
(Inherited from ModelObject.) |
![]() | Delete |
Deletes the rebar modifier from the model database.
(Inherited from BaseRebarModifier.) |
![]() | Equals |
Check if Identifiers of model objects are same.
(Inherited from ModelObject.) |
![]() | GetAffectedBars |
Gets the virtual bars affected by this splitter.
|
![]() ![]() | GetAllReportProperties |
Retrieves all properties for the model object in one hashtable.
Type for the returned value must be checked using type casting.
(Inherited from ModelObject.) |
![]() | GetAllUserProperties |
Retrieves all properties for the model object in one hashtable.
Type for the returned value must be checked using type casting.
(Inherited from ModelObject.) |
![]() | GetChildren |
Returns an enumerator of all the children model objects.
(Inherited from ModelObject.) |
![]() | GetCoordinateSystem |
Returns the coordinate system for the given model object.
(Inherited from ModelObject.) |
![]() | GetDoubleReportProperties |
Retrieves multiple double report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) |
![]() | GetDoubleUserProperties |
Retrieves all double properties for the model object.
(Inherited from ModelObject.) |
![]() | GetDynamicStringProperty |
Gets a dynamic string property from the model object.
(Inherited from ModelObject.) |
![]() | GetFatherComponent |
Returns the father component of the model object.
(Inherited from ModelObject.) |
![]() | GetHierarchicObjects |
Returns an enumerator of all the connected hierarchic objects.
(Inherited from ModelObject.) |
![]() | GetIntegerReportProperties |
Retrieves multiple integer report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) |
![]() | GetIntegerUserProperties |
Retrieves all integer properties for the model object.
(Inherited from ModelObject.) |
![]() | GetPhase |
Retrieves the phase of the model object (the phase number, the phase name,
the phase comment and whether the phase is the current one or not).
(Inherited from ModelObject.) |
![]() | GetReportProperty(String, Double) |
Retrieves a double property of the report for the model object.
(Inherited from ModelObject.) |
![]() | GetReportProperty(String, Int32) |
Retrieves an integer property of the report for the model object.
(Inherited from ModelObject.) |
![]() | GetReportProperty(String, String) |
Retrieves a string property of the report for the model object.
(Inherited from ModelObject.) |
![]() | GetStringReportProperties |
Retrieves multiple string report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) |
![]() | GetStringUserProperties |
Retrieves all string properties for the model object.
(Inherited from ModelObject.) |
![]() | GetUserProperty(String, Double) |
Retrieves a double property for the model object.
(Inherited from ModelObject.) |
![]() | GetUserProperty(String, Int32) |
Retrieves an integer property for the model object.
(Inherited from ModelObject.) |
![]() | GetUserProperty(String, String) |
Retrieves a string property for the model object.
(Inherited from ModelObject.) |
![]() | Insert |
Inserts the rebar modifier into the model database.
(Inherited from BaseRebarModifier.) |
![]() | Modify |
Modifies the existing rebar modifier in the model database to match the current one.
(Inherited from BaseRebarModifier.) |
![]() | Select |
Selects the rebar modifier from the model database. The identifier must be set.
(Inherited from BaseRebarModifier.) |
![]() | SetDynamicStringProperty |
Sets a dynamic string property for the model object.
(Inherited from ModelObject.) |
![]() | SetLabel |
Sets a label for an object when a new instance is created, this method must be called before Insert.
The label is used in plug-ins for identifying the changed object in modification.
(Inherited from ModelObject.) |
![]() | SetPhase |
Sets the phase of the model object.
(Inherited from ModelObject.) |
![]() | SetUserProperties |
Sets multiple properties for the model object.
(Inherited from ModelObject.) |
![]() | SetUserProperty(String, Double) |
Sets a double property for the model object.
(Inherited from ModelObject.) |
![]() | SetUserProperty(String, Int32) |
Sets an integer property for the model object.
(Inherited from ModelObject.) |
![]() | SetUserProperty(String, String) |
Sets a string property for the model object.
(Inherited from ModelObject.) |

The following example shows how to create and add a RebarSplitter, to a rebarset.
using Tekla.Structures.Model; using Tekla.Structures.Geometry3d; public class Example { public void Example1() { // Create and insert a rebarset (see the RebarSet example). var rebarSet = new RebarSet(); // Create the RebarSplitter var strip = new RebarSplitter(); strip.Father = rebarSet; strip.SplitType = RebarSplitter.SplitTypeEnum.LAPPING; strip.Lapping.LappingType = RebarLapping.LappingTypeEnum.CUSTOM_LAPPING; strip.Lapping.LapLength = 100; strip.StaggerType = RebarSplitter.StaggerTypeEnum.STAGGER_LEFT; strip.StaggerOffset = 200; strip.SplitOffset = 50; strip.Curve.AddContourPoint(new ContourPoint(new Point(400, 200, 0), null)); strip.Curve.AddContourPoint(new ContourPoint(new Point(400, 1000, 0), null)); strip.Insert(); } }