API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

RebarSpliceRebarSpliceTypeEnum Enumeration

The splice types.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public enum RebarSpliceTypeEnum
Members
  Member nameValueDescription
SPLICE_TYPE_LAP_RIGHT0 The first (left) bar extends over the second (right) bar.
SPLICE_TYPE_LAP_LEFT1 The second (right) bar extends over the first (left) bar.
SPLICE_TYPE_LAP_BOTH2 Both bars extend over each other.
SPLICE_TYPE_MUFF3 The bar ends are joined with a muff.
SPLICE_TYPE_WELD4 The bar ends are joined with a weld.
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.