API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

RebarSpacingZoneLengthType Property

Gets or sets a value indicating whether the length is absolute or relative. If the length is relative the length property is treated as a proportion of the overall available spacing length (from the associated RebarGuideline). The available spacing length is the guideline length less the calculated start and end offsets and less any fixed length spacing zones. An example of how relative length values are handled: With two relative length zones with proposed length values of 10 and 20 respectively the final calculated lengths will normally be 'available spacing length'*10/(10+20) and 'available spacing length'*20/(10+20) though the spacing algorithm may determine a different result in some situations.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public RebarSpacingZoneLengthEnum LengthType { get; set; }

Property Value

Type: RebarSpacingZoneLengthEnum
See Also