RebarPropertiesNullable Class

The RebarPropertiesNullable class defines the properties of the reinforcing bars affected by a RebarPropertyModifier.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.ModelRebarPropertiesNullable

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.3
Syntax
[SerializableAttribute]
public sealed class RebarPropertiesNullable

The RebarPropertiesNullable type exposes the following members.

Constructors
  NameDescription
Public methodRebarPropertiesNullable
Initializes a new instance of the RebarPropertiesNullable class.
Top
Properties
  NameDescription
Public propertyBendingRadius
Gets or sets the bending radius radius of the reinforcement.
Public propertyClass
Gets or sets the class of the reinforcement. The class is used to group reinforcements.
Public propertyGrade
Gets or sets the steel grade of the reinforcing bar. The grade indicates the strength of the steel used in reinforcing bars. It can also indicate other factors, such as the weldability or surface deformations of the bar.
Public propertyName
Gets or sets the name of the reinforcement.
Public propertyNumberingSeries
Gets or sets the numbering series of the reinforcement.
Public propertySize
Gets or sets the size of the reinforcement.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.
Previous
Next