API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

RebarProperties Class

The RebarProperties class defines the default properties of the reinforcing bars in a RebarSet.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.ModelRebarProperties

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public sealed class RebarProperties

The RebarProperties type exposes the following members.

Constructors
  NameDescription
Public methodRebarProperties
Initializes a new instance of the RebarProperties class.
Top
Properties
  NameDescription
Public propertyBendingRadius
Gets or sets the bending radius of the reinforcement.
Public propertyClass
Gets or sets the class of the reinforcement. The class is used to group reinforcements.
Public propertyGrade
Gets or sets the steel grade of the reinforcing bar. The grade indicates the strength of the steel used in reinforcing bars. It can also indicate other factors, such as the weldability or surface deformations of the bar.
Public propertyName
Gets or sets the name of the reinforcement.
Public propertyNumberingSeries
Gets or sets the numbering series of the reinforcement.
Public propertySize
Gets or sets the size of the reinforcement.
Top
See Also