API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

RebarMeshRebarMeshSpacingMethodEnum Enumeration

The ways to distribute the reinforcing bars with different spacings.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public enum RebarMeshSpacingMethodEnum
Members
  Member nameValueDescription
SPACING_TYPE_UNDEFINED0 The undefined spacing type.
SPACING_TYPE_SAME_DISTANCE1 Distributes the bars using the same distance for all bars.
SPACING_TYPE_MULTIPLE_VARYING_DISTANCES2 Varying distribution of the bars.
See Also