API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

RebarHookDataNullable Class

The RebarHookDataNullable class defines the hook at the end of a reinforcing bar. Hooks are used for anchoring purposes.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.ModelRebarHookDataNullable

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public sealed class RebarHookDataNullable

The RebarHookDataNullable type exposes the following members.

Constructors
  NameDescription
Public methodRebarHookDataNullable
Initializes a new instance of the RebarHookDataNullable class.
Top
Properties
  NameDescription
Public propertyAngle
Gets or sets the angle of the hook. The value is between -270 to +270 degrees.
Public propertyLength
Gets or sets the length of the straight part of the hook.
Public propertyRadius
Gets or sets the bending radius of the hook.
Public propertyRotation
Gets or sets the rotation of the hook.
Public propertyShape
Gets or sets the shape of the hook. The options are:
  • NO_HOOK. Sets the angle, radius and length to 0.
  • HOOK_90_DEGREES.
  • HOOK_135_DEGREES.
  • HOOK_180_DEGREES.
  • CUSTOM_HOOK. The angle, radius and length values have to be set manually.
Top
See Also
Was this helpful?
The feedback you give here is not visible to other users. We use your comments to improve the content.