API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

RebarHookDataShape Property

Defines the shape of the hook. The options are:
  • NO_HOOK. Sets the angle, radius and length to 0.
  • HOOK_90_DEGREES.
  • HOOK_135_DEGREES.
  • HOOK_180_DEGREES.
  • CUSTOM_HOOK. The angle, radius and length values have to be set manually.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public RebarHookDataRebarHookShapeEnum Shape { get; set; }

Property Value

Type: RebarHookDataRebarHookShapeEnum
See Also