API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ProjectInfoGetUserProperty Method (String, Double)

Retrieves a double property for the ProjectInfo.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public bool GetUserProperty(
	string Name,
	ref double Value
)

Parameters

Name
Type: SystemString
The name of the property to be retrieved.
Value
Type: SystemDouble
The return value.

Return Value

Type: Boolean
True if the value was returned successfully.
See Also