API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

ProjectInfoGetBasePointByName Method

Gets a base point by given name.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public static BasePoint GetBasePointByName(
	string name
)

Parameters

name
Type: SystemString
The name of the base point.

Return Value

Type: BasePoint
If found, the base point, otherwise empty base point.
See Also