API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

Profile Class

The Profile class defines the form of a cross section.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.ModelProfile

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public sealed class Profile

The Profile type exposes the following members.

Constructors
  NameDescription
Public methodProfile
Instantiates an empty profile.
Top
Properties
  NameDescription
Public propertyCode exampleProfileString
The profile in human-readable form.
Top
Methods
  NameDescription
Public methodStatic memberFormatProfileString
Formats profile string
Public methodStatic memberParseProfileString
Parses profile string
Top
See Also