![]() | PourObject Class |
The PourObject class represents a pour object in the model.

SystemObject
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelPourObject
Tekla.Structures.ModelObject
Tekla.Structures.ModelModelObject
Tekla.Structures.ModelPourObject
Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1

The PourObject type exposes the following members.

Name | Description | |
---|---|---|
![]() | PourObject |
Initializes a new instance of the PourObject class.
|

Name | Description | |
---|---|---|
![]() | Class |
Gets or sets the class of the pour object.
|
![]() | ConcreteMixture |
Gets or sets the concrete mixture of the pour.
|
![]() | Identifier |
The identifier of the object.
(Inherited from Object.) |
![]() | IsUpToDate | Gets if the object does not have a modification which is not shared. (Inherited from ModelObject.) |
![]() | ModificationTime | Gets latest time of the object was modified or created. (Inherited from ModelObject.) |
![]() | PourNumber |
Gets or sets the pour number of the pour.
|
![]() | PourType |
Gets or sets the pour type of the pour.
|

Name | Description | |
---|---|---|
![]() | CompareTo |
Compares Identifiers of model objects.
(Inherited from ModelObject.) |
![]() | Delete |
At the moment pour objects cannot be deleted.
(Overrides ModelObjectDelete.) |
![]() | Equals |
Check if Identifiers of model objects are same.
(Inherited from ModelObject.) |
![]() ![]() | GetAllReportProperties |
Retrieves all properties for the model object in one hashtable.
Type for the returned value must be checked using type casting.
(Inherited from ModelObject.) |
![]() | GetAllUserProperties |
Retrieves all properties for the model object in one hashtable.
Type for the returned value must be checked using type casting.
(Inherited from ModelObject.) |
![]() | GetAssembly | Obsolete.
Returns the assembly that the pour object belongs to.
|
![]() | GetChildren |
Returns an enumerator of all the children model objects.
(Inherited from ModelObject.) |
![]() | GetCoordinateSystem |
Returns the coordinate system for the given model object.
(Inherited from ModelObject.) |
![]() | GetDoubleReportProperties |
Retrieves multiple double report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) |
![]() | GetDoubleUserProperties |
Retrieves all double properties for the model object.
(Inherited from ModelObject.) |
![]() | GetDynamicStringProperty |
Gets a dynamic string property from the model object.
(Inherited from ModelObject.) |
![]() | GetFatherComponent |
Returns the father component of the model object.
(Inherited from ModelObject.) |
![]() | GetFatherPourUnit |
Returns the pour unit that the pour object belongs to.
|
![]() | GetHierarchicObjects |
Returns an enumerator of all the connected hierarchic objects.
(Inherited from ModelObject.) |
![]() | GetIntegerReportProperties |
Retrieves multiple integer report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) |
![]() | GetIntegerUserProperties |
Retrieves all integer properties for the model object.
(Inherited from ModelObject.) |
![]() | GetObjects |
Returns an enumerator of all objects related to pour.
|
![]() | GetParts |
Returns an enumerator of all parts related to pour.
|
![]() | GetPhase |
Retrieves the phase of the model object (the phase number, the phase name,
the phase comment and whether the phase is the current one or not).
(Inherited from ModelObject.) |
![]() | GetPourPolymeshes |
Returns a new polymesh enumerator based on merged faces of the pour object in the current plane.
|
![]() | GetReportProperty(String, Double) |
Retrieves a double property of the report for the model object.
(Inherited from ModelObject.) |
![]() | GetReportProperty(String, Int32) |
Retrieves an integer property of the report for the model object.
(Inherited from ModelObject.) |
![]() | GetReportProperty(String, String) |
Retrieves a string property of the report for the model object.
(Inherited from ModelObject.) |
![]() | GetSolid |
Returns the solid of the pour object.
|
![]() | GetStringReportProperties |
Retrieves multiple string report properties for the model object. It is faster
to fetch multiple properties at once.
(Inherited from ModelObject.) |
![]() | GetStringUserProperties |
Retrieves all string properties for the model object.
(Inherited from ModelObject.) |
![]() | GetSurfaceObjects |
Returns an enumerator of all the connected surface objects.
|
![]() | GetUserProperty(String, Double) |
Retrieves a double property for the model object.
(Inherited from ModelObject.) |
![]() | GetUserProperty(String, Int32) |
Retrieves an integer property for the model object.
(Inherited from ModelObject.) |
![]() | GetUserProperty(String, String) |
Retrieves a string property for the model object.
(Inherited from ModelObject.) |
![]() | Insert |
At the moment pour objects cannot be inserted.
(Overrides ModelObjectInsert.) |
![]() | Modify |
Modifies the pour object with the given identifier.
(Overrides ModelObjectModify.) |
![]() | Select |
Selects the pour object instance from the model. The identifier of the instance must be set.
(Overrides ModelObjectSelect.) |
![]() | SetDynamicStringProperty |
Sets a dynamic string property for the model object.
(Inherited from ModelObject.) |
![]() | SetLabel |
Sets a label for an object when a new instance is created, this method must be called before Insert.
The label is used in plug-ins for identifying the changed object in modification.
(Inherited from ModelObject.) |
![]() | SetPhase |
Sets the phase of the model object.
(Inherited from ModelObject.) |
![]() | SetUserProperties |
Sets multiple properties for the model object.
(Inherited from ModelObject.) |
![]() | SetUserProperty(String, Double) |
Sets a double property for the model object.
(Inherited from ModelObject.) |
![]() | SetUserProperty(String, Int32) |
Sets an integer property for the model object.
(Inherited from ModelObject.) |
![]() | SetUserProperty(String, String) |
Sets a string property for the model object.
(Inherited from ModelObject.) |

using Tekla.Structures.Model; using Tekla.Structures.Geometry3d; using System; using System.Collections; public class Example { public void Example1() { Beam beam = new Beam(new Point(1000, 1000, 400), new Point(3000, 1000, 400)); beam.Profile.ProfileString = "380*380"; beam.Material.MaterialString = "K40-1"; beam.CastUnitType = Part.CastUnitTypeEnum.CAST_IN_PLACE; if (beam.Insert()) { Beam beam2 = new Beam(new Point(800, 1000, 0), new Point(800, 1000, 3000)); beam2.Profile.ProfileString = "380*380"; beam2.Material.MaterialString = "K40-1"; beam2.CastUnitType = Part.CastUnitTypeEnum.CAST_IN_PLACE; if (beam2.Insert()) { new Model().CommitChanges(); ModelObjectEnumerator pours = beam.GetPours(); while(pours.MoveNext()) { PourObject pour = pours.Current as PourObject; if(pour != null) { Solid solid = pour.GetSolid(); if(solid != null) Console.WriteLine("Fetching solid from pour successfully!"); } } } } } }