API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

Position Class

The Position class defines how a part is positioned relative to the input.
Inheritance Hierarchy
SystemObject
  Tekla.Structures.ModelPosition

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
[SerializableAttribute]
public sealed class Position

The Position type exposes the following members.

Constructors
  NameDescription
Public methodPosition
Creates a new position instance.
Top
Properties
  NameDescription
Public propertyDepth
Indicates the positioning in the depth sense.
Public propertyDepthOffset
The offset away from the Depth value.
Public propertyPlane
Indicates the positioning in the plane sense.
Public propertyPlaneOffset
The offset away from the Plane value.
Public propertyRotation
Indicates the positioning in the rotational sense.
Public propertyRotationOffset
The offset away from the Rotation value.
Top
Examples
Defining the position of a bolt array instance:
using Tekla.Structures.Model;

public class Example
{
       public void Example1()
       {
           BoltArray MyBoltArray = new BoltArray();

           MyBoltArray.Position.Depth = Position.DepthEnum.MIDDLE;
           MyBoltArray.Position.DepthOffset = 3;
           MyBoltArray.Position.Plane = Position.PlaneEnum.MIDDLE;
           MyBoltArray.Position.PlaneOffset = 1;
           MyBoltArray.Position.Rotation = Position.RotationEnum.FRONT;
           MyBoltArray.Position.RotationOffset = 2;
       }
}
See Also