API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PolymeshValidate Method

Converts a
FacetedBrep
to a polymesh and validates.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public static bool Validate(
	FacetedBrep brep,
	PolymeshPolymeshCheckerFlags checkCriteria,
	ref List<KeyValuePair<int, PolymeshPolymeshHealthCheckEnum>> invalidInfo
)

Parameters

brep
Type: Tekla.Structures.Geometry3dFacetedBrep
The FacetedBrep to be converted and validated
checkCriteria
Type: Tekla.Structures.ModelPolymeshPolymeshCheckerFlags
The flags to indicate what to check
invalidInfo
Type: System.Collections.GenericListKeyValuePairInt32, PolymeshPolymeshHealthCheckEnum
The problematic faces' indices and their failed reasons, (-1, PolymeshUndefined) is for unknown reason for uncertain face. No inner loops checked further if outer loop found error.

Return Value

Type: Boolean
True if valid, false if error found
See Also