API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PolymeshConvertInvalidInfoFromStruct Method

Convert a struct of invalid info to a list of pairs of outer loop index and error code. Read indexes and error codes from the integer list.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public static List<KeyValuePair<int, PolymeshPolymeshHealthCheckEnum>> ConvertInvalidInfoFromStruct(
	ref dotPolymeshValidateInvalidInfo_t input
)

Parameters

input
Type: dotPolymeshValidateInvalidInfo_t
Invalid info passed from TS core

Return Value

Type: ListKeyValuePairInt32, PolymeshPolymeshHealthCheckEnum
A list of pairs of outer loop index, error code
See Also