![]() | Polymesh Class |
The Polygon class represents a polygon object that has its corners at the given points.
The Polygon class represents a polygon object that has its corners at the given points.

Namespace: Tekla.Structures.Model
Assembly: Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1

The Polymesh type exposes the following members.



Name | Description | |
---|---|---|
![]() ![]() | CompareFingerprints |
Compares two fingerprints
|
![]() ![]() | Convert |
Converts a struct of polymeshes to a list of FacetedBrep |
![]() ![]() | ConvertInvalidInfoFromStruct |
Convert a struct of invalid info to a list of pairs of outer loop index and error code.
Read indexes and error codes from the integer list.
|
![]() ![]() | ConvertToStruct |
Converts a FacetedBrep |
![]() ![]() | Fingerprint |
Gets fingerprint information for input brep
|
![]() | FromStruct |
Converts a struct of polymesh to a FacetedBrep |
![]() ![]() | GetSolidBrep |
Gets the cleaned Brep
|
![]() | ToStruct |
Converts a FacetedBrep |
![]() ![]() | Validate |
Converts a FacetedBrep |