API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PolygonWeldGetLogicalWeld Method

Gets the logical weld where the weld belongs. Returns false if the weld does not belong to any logical weld.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public bool GetLogicalWeld(
	ref LogicalWeld LogicalWeld
)

Parameters

LogicalWeld
Type: Tekla.Structures.ModelLogicalWeld
An initialized logical weld object.

Return Value

Type: Boolean
True if the logical weld was selected correctly; false otherwise.
See Also