API Reference

Detailed and full API reference helps you master Tekla development

This is the most recent version of Tekla Open API.
For older versions, please visit Tekla Warehouse.

PolygonNode Constructor

Initializes a new instance of the PolygonNode class.

Namespace:  Tekla.Structures.Model
Assembly:  Tekla.Structures.Model (in Tekla.Structures.Model.dll) Version: 2023.0.1
Syntax
public PolygonNode(
	Contour contour,
	bool isAutomaticNode = false
)

Parameters

contour
Type: Tekla.Structures.ModelContour
The contour points of the node.
isAutomaticNode (Optional)
Type: SystemBoolean
true if the node represents an automatically generated extension.
See Also